summaryrefslogtreecommitdiffstats
path: root/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/remotecontrolledcar/controller/CMakeLists.txt')
-rw-r--r--examples/dbus/remotecontrolledcar/controller/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt b/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
index 2075261d18..5ad9d2e51d 100644
--- a/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
+++ b/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
@@ -9,8 +9,10 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/dbus/remotecontrolledcar/controller")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS DBus)
find_package(Qt6 COMPONENTS Widgets)
@@ -27,9 +29,12 @@ add_qt_gui_executable(controller
${controller_SRCS} # special case
)
target_link_libraries(controller PUBLIC
+ Qt::Core
Qt::DBus
+ Qt::Gui
Qt::Widgets
)
+
install(TARGETS controller
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"