summaryrefslogtreecommitdiffstats
path: root/examples/embedded/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/embedded/CMakeLists.txt')
-rw-r--r--examples/embedded/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/embedded/CMakeLists.txt b/examples/embedded/CMakeLists.txt
index bd7720809a..84292edccc 100644
--- a/examples/embedded/CMakeLists.txt
+++ b/examples/embedded/CMakeLists.txt
@@ -1,5 +1,8 @@
# Generated from embedded.pro.
+if(NOT TARGET Qt::Gui OR (NOT embedded AND NOT x11))
+ return()
+endif()
add_subdirectory(styleexample)
add_subdirectory(raycasting)
add_subdirectory(flickable)