summaryrefslogtreecommitdiffstats
path: root/examples/embedded/raycasting/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/embedded/raycasting/CMakeLists.txt')
-rw-r--r--examples/embedded/raycasting/CMakeLists.txt52
1 files changed, 0 insertions, 52 deletions
diff --git a/examples/embedded/raycasting/CMakeLists.txt b/examples/embedded/raycasting/CMakeLists.txt
deleted file mode 100644
index c58f8cf6fa..0000000000
--- a/examples/embedded/raycasting/CMakeLists.txt
+++ /dev/null
@@ -1,52 +0,0 @@
-# Generated from raycasting.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(raycasting LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/embedded/raycasting")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-
-qt_add_executable(raycasting
- raycasting.cpp
-)
-set_target_properties(raycasting PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(raycasting PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-
-# Resources:
-set(raycasting_resource_files
- "textures.png"
-)
-
-qt6_add_resources(raycasting "raycasting"
- PREFIX
- "/"
- FILES
- ${raycasting_resource_files}
-)
-
-install(TARGETS raycasting
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)