summaryrefslogtreecommitdiffstats
path: root/examples/embedded/raycasting/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/embedded/raycasting/CMakeLists.txt')
-rw-r--r--examples/embedded/raycasting/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/examples/embedded/raycasting/CMakeLists.txt b/examples/embedded/raycasting/CMakeLists.txt
deleted file mode 100644
index b2e66c2442..0000000000
--- a/examples/embedded/raycasting/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-cmake_minimum_required(VERSION 3.16)
-project(raycasting LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/embedded/raycasting")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_add_executable(raycasting
- raycasting.cpp
-)
-
-set_target_properties(raycasting PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(raycasting PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-# Resources:
-set(raycasting_resource_files
- "textures.png"
-)
-
-qt_add_resources(raycasting "raycasting"
- PREFIX
- "/"
- FILES
- ${raycasting_resource_files}
-)
-
-install(TARGETS raycasting
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)