summaryrefslogtreecommitdiffstats
path: root/examples/embedded/raycasting/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/embedded/raycasting/CMakeLists.txt')
-rw-r--r--examples/embedded/raycasting/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/examples/embedded/raycasting/CMakeLists.txt b/examples/embedded/raycasting/CMakeLists.txt
index 0b48de26a5..86a3042f86 100644
--- a/examples/embedded/raycasting/CMakeLists.txt
+++ b/examples/embedded/raycasting/CMakeLists.txt
@@ -9,17 +9,34 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/embedded/raycasting")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(raycasting
- raycasting.cpp raycasting.qrc
+ raycasting.cpp
)
target_link_libraries(raycasting PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
+
+# Resources:
+set(raycasting_resource_files
+ "textures.png"
+)
+
+qt6_add_resources(raycasting "raycasting"
+ PREFIX
+ "/"
+ FILES
+ ${raycasting_resource_files}
+)
+
install(TARGETS raycasting
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"