summaryrefslogtreecommitdiffstats
path: root/examples/embedded/styleexample/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/embedded/styleexample/CMakeLists.txt')
-rw-r--r--examples/embedded/styleexample/CMakeLists.txt28
1 files changed, 26 insertions, 2 deletions
diff --git a/examples/embedded/styleexample/CMakeLists.txt b/examples/embedded/styleexample/CMakeLists.txt
index a0ec3d738a..ac03e58346 100644
--- a/examples/embedded/styleexample/CMakeLists.txt
+++ b/examples/embedded/styleexample/CMakeLists.txt
@@ -9,18 +9,42 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/embedded/styleexample")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(styleexample
main.cpp
stylewidget.cpp stylewidget.h stylewidget.ui
- styleexample.qrc # special case: add
)
target_link_libraries(styleexample PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
+
+
+# Resources:
+set(styleexample_resource_files
+ "files/add.png"
+ "files/application.qss"
+ "files/blue.qss"
+ "files/khaki.qss"
+ "files/nature_1.jpg"
+ "files/nostyle.qss"
+ "files/remove.png"
+ "files/transparent.qss"
+)
+
+qt6_add_resources(styleexample "styleexample"
+ PREFIX
+ "/"
+ FILES
+ ${styleexample_resource_files}
+)
+
install(TARGETS styleexample
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"