summaryrefslogtreecommitdiffstats
path: root/examples/gui/analogclock/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/gui/analogclock/CMakeLists.txt')
-rw-r--r--examples/gui/analogclock/CMakeLists.txt18
1 files changed, 7 insertions, 11 deletions
diff --git a/examples/gui/analogclock/CMakeLists.txt b/examples/gui/analogclock/CMakeLists.txt
index 4c694e425e..0cd882a722 100644
--- a/examples/gui/analogclock/CMakeLists.txt
+++ b/examples/gui/analogclock/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from analogclock.pro.
-
cmake_minimum_required(VERSION 3.16)
project(analogclock LANGUAGES CXX)
@@ -14,33 +12,31 @@ if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/gui/gui_analogclock") # special case
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/gui/gui_analogclock")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-qt_add_executable(gui_analogclock # special case: renamed target
+qt_add_executable(gui_analogclock
../rasterwindow/rasterwindow.cpp ../rasterwindow/rasterwindow.h
main.cpp
)
-set_target_properties(gui_analogclock PROPERTIES # special case
+set_target_properties(gui_analogclock PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_include_directories(gui_analogclock PUBLIC # special case
+target_include_directories(gui_analogclock PUBLIC
../rasterwindow
)
-# special case begin
-target_link_libraries(gui_analogclock PUBLIC # special case
+target_link_libraries(gui_analogclock PUBLIC
Qt::Gui
)
-# special case end
-target_link_libraries(gui_analogclock PUBLIC # special case
+target_link_libraries(gui_analogclock PUBLIC
Qt::Core
Qt::Gui
)
-install(TARGETS gui_analogclock # special case
+install(TARGETS gui_analogclock
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"