summaryrefslogtreecommitdiffstats
path: root/examples/gui/rasterwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/gui/rasterwindow/CMakeLists.txt')
-rw-r--r--examples/gui/rasterwindow/CMakeLists.txt20
1 files changed, 16 insertions, 4 deletions
diff --git a/examples/gui/rasterwindow/CMakeLists.txt b/examples/gui/rasterwindow/CMakeLists.txt
index 667f91c268..61255f3038 100644
--- a/examples/gui/rasterwindow/CMakeLists.txt
+++ b/examples/gui/rasterwindow/CMakeLists.txt
@@ -1,6 +1,18 @@
+# Generated from rasterwindow.pro.
+
+#####################################################################
+## rasterwindow Binary:
+#####################################################################
+
add_qt_executable(rasterwindow
- SOURCES
- main.cpp
- rasterwindow.cpp rasterwindow.h
- LIBRARIES Qt::Core Qt::Test Qt::Gui
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/gui/rasterwindow"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/gui/rasterwindow"
+ SOURCES
+ main.cpp
+ rasterwindow.cpp rasterwindow.h
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ LIBRARIES # special case
+ Qt::Gui
)