summaryrefslogtreecommitdiffstats
path: root/examples/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/CMakeLists.txt')
-rw-r--r--examples/network/CMakeLists.txt42
1 files changed, 21 insertions, 21 deletions
diff --git a/examples/network/CMakeLists.txt b/examples/network/CMakeLists.txt
index c28c951b69..fd61e75aef 100644
--- a/examples/network/CMakeLists.txt
+++ b/examples/network/CMakeLists.txt
@@ -3,36 +3,36 @@
if(NOT TARGET Qt::Network)
return()
endif()
-add_subdirectory(download)
-add_subdirectory(downloadmanager)
+qt_internal_add_example(download)
+qt_internal_add_example(downloadmanager)
if(NOT INTEGRITY)
- add_subdirectory(dnslookup)
+ qt_internal_add_example(dnslookup)
endif()
if(TARGET Qt::Widgets)
- add_subdirectory(blockingfortuneclient)
- add_subdirectory(broadcastreceiver)
- add_subdirectory(broadcastsender)
- add_subdirectory(http)
- add_subdirectory(loopback)
- add_subdirectory(threadedfortuneserver)
- add_subdirectory(googlesuggest)
- add_subdirectory(torrent)
- add_subdirectory(multicastreceiver)
- add_subdirectory(multicastsender)
- add_subdirectory(fortuneclient)
- add_subdirectory(fortuneserver)
+ qt_internal_add_example(blockingfortuneclient)
+ qt_internal_add_example(broadcastreceiver)
+ qt_internal_add_example(broadcastsender)
+ qt_internal_add_example(http)
+ qt_internal_add_example(loopback)
+ qt_internal_add_example(threadedfortuneserver)
+ qt_internal_add_example(googlesuggest)
+ qt_internal_add_example(torrent)
+ qt_internal_add_example(multicastreceiver)
+ qt_internal_add_example(multicastsender)
+ qt_internal_add_example(fortuneclient)
+ qt_internal_add_example(fortuneserver)
endif()
if(QT_FEATURE_processenvironment AND TARGET Qt::Widgets)
- add_subdirectory(network-chat)
+ qt_internal_add_example(network-chat)
endif()
if(QT_FEATURE_ssl AND TARGET Qt::Widgets)
- add_subdirectory(securesocketclient)
+ qt_internal_add_example(securesocketclient)
endif()
if(QT_FEATURE_dtls AND TARGET Qt::Widgets)
- add_subdirectory(secureudpserver)
- add_subdirectory(secureudpclient)
+ qt_internal_add_example(secureudpserver)
+ qt_internal_add_example(secureudpclient)
endif()
if(QT_FEATURE_sctp AND TARGET Qt::Widgets)
- add_subdirectory(multistreamserver)
- add_subdirectory(multistreamclient)
+ qt_internal_add_example(multistreamserver)
+ qt_internal_add_example(multistreamclient)
endif()