summaryrefslogtreecommitdiffstats
path: root/examples/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/CMakeLists.txt')
-rw-r--r--examples/network/CMakeLists.txt56
1 files changed, 27 insertions, 29 deletions
diff --git a/examples/network/CMakeLists.txt b/examples/network/CMakeLists.txt
index b6ae618d1d..6222bb7c8b 100644
--- a/examples/network/CMakeLists.txt
+++ b/examples/network/CMakeLists.txt
@@ -1,38 +1,36 @@
-# Generated from network.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-if(NOT TARGET Qt::Network)
+if(NOT TARGET Qt6::Network)
return()
endif()
-add_subdirectory(download)
-add_subdirectory(downloadmanager)
-if(NOT INTEGRITY)
- add_subdirectory(dnslookup)
+if(NOT INTEGRITY AND NOT ANDROID)
+ qt_internal_add_example(dnslookup)
endif()
-if(TARGET Qt::Widgets)
- add_subdirectory(blockingfortuneclient)
- add_subdirectory(broadcastreceiver)
- add_subdirectory(broadcastsender)
- add_subdirectory(http)
- add_subdirectory(loopback)
- add_subdirectory(threadedfortuneserver)
- add_subdirectory(googlesuggest)
- # add_subdirectory(torrent) FIXME: This does not find its ui file:-/ # special case
- add_subdirectory(multicastreceiver)
- add_subdirectory(multicastsender)
- add_subdirectory(fortuneclient)
- add_subdirectory(fortuneserver)
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(blockingfortuneclient)
+ qt_internal_add_example(broadcastreceiver)
+ qt_internal_add_example(broadcastsender)
+ qt_internal_add_example(http)
+ qt_internal_add_example(threadedfortuneserver)
+ qt_internal_add_example(torrent)
+ qt_internal_add_example(multicastreceiver)
+ qt_internal_add_example(multicastsender)
+ qt_internal_add_example(fortuneclient)
+ qt_internal_add_example(fortuneserver)
+ qt_internal_add_example(rsslisting)
endif()
-if(QT_FEATURE_processenvironment AND TARGET Qt::Widgets)
- add_subdirectory(network-chat)
+if(QT_FEATURE_processenvironment AND TARGET Qt6::Widgets)
+ qt_internal_add_example(network-chat)
endif()
-if(QT_FEATURE_ssl AND TARGET Qt::Widgets)
- add_subdirectory(securesocketclient)
+if(QT_FEATURE_ssl AND TARGET Qt6::Widgets)
+ qt_internal_add_example(securesocketclient)
endif()
-if(QT_FEATURE_dtls AND TARGET Qt::Widgets)
- add_subdirectory(secureudpserver)
- add_subdirectory(secureudpclient)
+if(QT_FEATURE_dtls AND TARGET Qt6::Widgets)
+ qt_internal_add_example(secureudpserver)
+ qt_internal_add_example(secureudpclient)
endif()
-if(QT_FEATURE_sctp AND TARGET Qt::Widgets)
- add_subdirectory(multistreamserver)
- add_subdirectory(multistreamclient)
+if(QT_FEATURE_sctp AND TARGET Qt6::Widgets)
+ qt_internal_add_example(multistreamserver)
+ qt_internal_add_example(multistreamclient)
endif()