summaryrefslogtreecommitdiffstats
path: root/examples/network/bearermonitor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/bearermonitor/CMakeLists.txt')
-rw-r--r--examples/network/bearermonitor/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/examples/network/bearermonitor/CMakeLists.txt b/examples/network/bearermonitor/CMakeLists.txt
index eb992a0c58..4e8bfca813 100644
--- a/examples/network/bearermonitor/CMakeLists.txt
+++ b/examples/network/bearermonitor/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/network/bearermonitor")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -30,6 +30,12 @@ target_link_libraries(bearermonitor PUBLIC
Qt::Widgets
)
+if(WIN32)
+ target_link_libraries(bearermonitor PUBLIC
+ ws2_32
+ )
+endif()
+
install(TARGETS bearermonitor
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"