summaryrefslogtreecommitdiffstats
path: root/examples/network/download/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/download/CMakeLists.txt')
-rw-r--r--examples/network/download/CMakeLists.txt36
1 files changed, 23 insertions, 13 deletions
diff --git a/examples/network/download/CMakeLists.txt b/examples/network/download/CMakeLists.txt
index 868685fd0a..0ec20216b5 100644
--- a/examples/network/download/CMakeLists.txt
+++ b/examples/network/download/CMakeLists.txt
@@ -1,18 +1,28 @@
# Generated from download.pro.
-#####################################################################
-## download Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(download LANGUAGES CXX)
-add_qt_executable(download
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/download"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/download"
- SOURCES
- main.cpp
- LIBRARIES
- Qt::Network
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Core)
+find_package(Qt5 COMPONENTS Network)
+
+add_executable(download
+ main.cpp
+)
+target_link_libraries(download PUBLIC
+ Qt::Core
+ Qt::Network
)
-#### Keys ignored in scope 1:.:download.pro:<NONE>:
-# CONFIG = "-app_bundle"
+install(TARGETS download
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)