summaryrefslogtreecommitdiffstats
path: root/examples/network/http/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/http/CMakeLists.txt')
-rw-r--r--examples/network/http/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/network/http/CMakeLists.txt b/examples/network/http/CMakeLists.txt
index d9f50f5c9d..d7ad5adaa6 100644
--- a/examples/network/http/CMakeLists.txt
+++ b/examples/network/http/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/network/http")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/network/http")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)