summaryrefslogtreecommitdiffstats
path: root/examples/network/network-chat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/network-chat/CMakeLists.txt')
-rw-r--r--examples/network/network-chat/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/network/network-chat/CMakeLists.txt b/examples/network/network-chat/CMakeLists.txt
new file mode 100644
index 0000000000..56cd632529
--- /dev/null
+++ b/examples/network/network-chat/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from network-chat.pro.
+
+#####################################################################
+## network-chat Binary:
+#####################################################################
+
+add_qt_executable(network-chat
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/network-chat"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/network-chat"
+ SOURCES
+ chatdialog.cpp chatdialog.h chatdialog.ui
+ client.cpp client.h
+ connection.cpp connection.h
+ main.cpp
+ peermanager.cpp peermanager.h
+ server.cpp server.h
+ LIBRARIES
+ Qt::Network
+ Qt::Widgets
+)