summaryrefslogtreecommitdiffstats
path: root/examples/network/network-chat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/network-chat/CMakeLists.txt')
-rw-r--r--examples/network/network-chat/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/network/network-chat/CMakeLists.txt b/examples/network/network-chat/CMakeLists.txt
index bc07905c26..3c3220148a 100644
--- a/examples/network/network-chat/CMakeLists.txt
+++ b/examples/network/network-chat/CMakeLists.txt
@@ -8,7 +8,7 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/network/network-chat")
@@ -23,10 +23,12 @@ qt_add_executable(network-chat
peermanager.cpp peermanager.h
server.cpp server.h
)
+
set_target_properties(network-chat PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(network-chat PUBLIC
Qt::Core
Qt::Gui