summaryrefslogtreecommitdiffstats
path: root/examples/network/torrent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/torrent/CMakeLists.txt')
-rw-r--r--examples/network/torrent/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/network/torrent/CMakeLists.txt b/examples/network/torrent/CMakeLists.txt
index 0766d208b7..7eea3d02bc 100644
--- a/examples/network/torrent/CMakeLists.txt
+++ b/examples/network/torrent/CMakeLists.txt
@@ -35,6 +35,10 @@ qt_add_executable(torrent
torrentserver.cpp torrentserver.h
trackerclient.cpp trackerclient.h
)
+set_target_properties(torrent PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_include_directories(torrent PUBLIC forms) # special case
target_link_libraries(torrent PUBLIC
Qt::Core