summaryrefslogtreecommitdiffstats
path: root/examples/opengl/hellogles3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/hellogles3/CMakeLists.txt')
-rw-r--r--examples/opengl/hellogles3/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/opengl/hellogles3/CMakeLists.txt b/examples/opengl/hellogles3/CMakeLists.txt
index cf1f66c6e6..fdf6fa337a 100644
--- a/examples/opengl/hellogles3/CMakeLists.txt
+++ b/examples/opengl/hellogles3/CMakeLists.txt
@@ -8,7 +8,7 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/hellogles3")
@@ -20,17 +20,18 @@ qt_add_executable(hellogles3
glwindow.cpp glwindow.h
main.cpp
)
+
set_target_properties(hellogles3 PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(hellogles3 PUBLIC
Qt::Core
Qt::Gui
Qt::OpenGL
)
-
# Resources:
set(hellogles3_resource_files
"qtlogo.png"