summaryrefslogtreecommitdiffstats
path: root/examples/opengl/hellowindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/hellowindow/CMakeLists.txt')
-rw-r--r--examples/opengl/hellowindow/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/examples/opengl/hellowindow/CMakeLists.txt b/examples/opengl/hellowindow/CMakeLists.txt
index 341b52b2cb..58bd3fc362 100644
--- a/examples/opengl/hellowindow/CMakeLists.txt
+++ b/examples/opengl/hellowindow/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/opengl/hellowindow")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -18,13 +18,11 @@ add_qt_gui_executable(hellowindow
hellowindow.cpp hellowindow.h
main.cpp
)
-target_link_libraries(hellowindow PRIVATE
- Qt::CorePrivate
- Qt::GuiPrivate
-)
target_link_libraries(hellowindow PUBLIC
Qt::Core
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
)
install(TARGETS hellowindow