summaryrefslogtreecommitdiffstats
path: root/examples/opengl/qopenglwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/qopenglwidget/CMakeLists.txt')
-rw-r--r--examples/opengl/qopenglwidget/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/examples/opengl/qopenglwidget/CMakeLists.txt b/examples/opengl/qopenglwidget/CMakeLists.txt
deleted file mode 100644
index 259ebdc43d..0000000000
--- a/examples/opengl/qopenglwidget/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(qopenglwidget LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/qopenglwidget")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui OpenGL OpenGLWidgets Widgets)
-
-qt_add_executable(qopenglwidget
- bubble.cpp bubble.h
- glwidget.cpp glwidget.h
- main.cpp
- mainwindow.cpp mainwindow.h
-)
-
-set_target_properties(qopenglwidget PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(qopenglwidget PUBLIC
- Qt::Core
- Qt::Gui
- Qt::OpenGL
- Qt::OpenGLWidgets
- Qt::Widgets
-)
-
-# Resources:
-set(texture_resource_files
- "qt.png"
-)
-
-qt6_add_resources(qopenglwidget "texture"
- PREFIX
- "/"
- FILES
- ${texture_resource_files}
-)
-
-install(TARGETS qopenglwidget
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)