summaryrefslogtreecommitdiffstats
path: root/examples/opengl/textures/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/textures/CMakeLists.txt')
-rw-r--r--examples/opengl/textures/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/opengl/textures/CMakeLists.txt b/examples/opengl/textures/CMakeLists.txt
index adf9049df4..7d67a892c7 100644
--- a/examples/opengl/textures/CMakeLists.txt
+++ b/examples/opengl/textures/CMakeLists.txt
@@ -8,7 +8,7 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/textures")
@@ -20,10 +20,12 @@ qt_add_executable(textures
main.cpp
window.cpp window.h
)
+
set_target_properties(textures PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(textures PUBLIC
Qt::Core
Qt::Gui
@@ -32,7 +34,6 @@ target_link_libraries(textures PUBLIC
Qt::Widgets
)
-
# Resources:
set(textures_resource_files
"images/side1.png"