summaryrefslogtreecommitdiffstats
path: root/examples/opengl/threadedqopenglwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/threadedqopenglwidget/CMakeLists.txt')
-rw-r--r--examples/opengl/threadedqopenglwidget/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/examples/opengl/threadedqopenglwidget/CMakeLists.txt b/examples/opengl/threadedqopenglwidget/CMakeLists.txt
deleted file mode 100644
index 66e8e068fb..0000000000
--- a/examples/opengl/threadedqopenglwidget/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-# Generated from threadedqopenglwidget.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(threadedqopenglwidget LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/threadedqopenglwidget")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS OpenGL)
-find_package(Qt6 COMPONENTS OpenGLWidgets)
-
-qt_add_executable(threadedqopenglwidget
- glwidget.cpp glwidget.h
- main.cpp
- mainwindow.cpp mainwindow.h
-)
-set_target_properties(threadedqopenglwidget PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(threadedqopenglwidget PUBLIC
- Qt::Core
- Qt::Gui
- Qt::OpenGL
- Qt::OpenGLWidgets
- Qt::Widgets
-)
-
-install(TARGETS threadedqopenglwidget
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)