summaryrefslogtreecommitdiffstats
path: root/examples/qpa/qrasterwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qpa/qrasterwindow/CMakeLists.txt')
-rw-r--r--examples/qpa/qrasterwindow/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/examples/qpa/qrasterwindow/CMakeLists.txt b/examples/qpa/qrasterwindow/CMakeLists.txt
index 1567d38285..8fd75f1079 100644
--- a/examples/qpa/qrasterwindow/CMakeLists.txt
+++ b/examples/qpa/qrasterwindow/CMakeLists.txt
@@ -3,20 +3,24 @@
cmake_minimum_required(VERSION 3.14)
project(qrasterwindow LANGUAGES CXX)
-find_package(Qt6 COMPONENTS Gui) # special case
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/qpa/qrasterwindow")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
add_qt_gui_executable(qrasterwindow
main.cpp
)
-target_link_libraries(qrasterwindow PUBLIC Qt::Gui) # special case: add
+target_link_libraries(qrasterwindow PUBLIC
+ Qt::Core
+ Qt::Gui
+)
install(TARGETS qrasterwindow
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"