summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/examples/qtconcurrent/CMakeLists.txt b/examples/qtconcurrent/CMakeLists.txt
index 13cfed8773..ed1be7ec4d 100644
--- a/examples/qtconcurrent/CMakeLists.txt
+++ b/examples/qtconcurrent/CMakeLists.txt
@@ -1,5 +1,7 @@
-if(TARGET Qt::Gui)
- add_subdirectory(map)
+# Generated from qtconcurrent.pro.
+
+if(NOT TARGET Qt::Concurrent)
+ return()
endif()
if(TARGET Qt::Widgets)
add_subdirectory(imagescaling)
@@ -7,3 +9,6 @@ if(TARGET Qt::Widgets)
add_subdirectory(runfunction)
add_subdirectory(wordcount)
endif()
+if(TARGET Qt::Gui)
+ add_subdirectory(map)
+endif()