summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/imagescaling/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/imagescaling/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/imagescaling/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/examples/qtconcurrent/imagescaling/CMakeLists.txt b/examples/qtconcurrent/imagescaling/CMakeLists.txt
index bb1677983d..9f84662270 100644
--- a/examples/qtconcurrent/imagescaling/CMakeLists.txt
+++ b/examples/qtconcurrent/imagescaling/CMakeLists.txt
@@ -15,11 +15,7 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qtconcurrent/imagescaling")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Concurrent)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS Network)
+find_package(Qt6 REQUIRED COMPONENTS Concurrent Core Gui Network Widgets)
qt_add_executable(imagescaling
downloaddialog.cpp downloaddialog.h downloaddialog.ui