summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/map/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/map/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/map/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/qtconcurrent/map/CMakeLists.txt b/examples/qtconcurrent/map/CMakeLists.txt
index 1707825b8f..e5a3ba1c66 100644
--- a/examples/qtconcurrent/map/CMakeLists.txt
+++ b/examples/qtconcurrent/map/CMakeLists.txt
@@ -9,17 +9,19 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/qtconcurrent/map")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Concurrent)
-find_package(Qt6 COMPONENTS Gui) # special case
add_executable(mapdemo
main.cpp
)
target_link_libraries(mapdemo PUBLIC
Qt::Concurrent
- Qt::Gui # special case
+ Qt::Core
+ Qt::Gui
)
install(TARGETS mapdemo
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"