summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/progressdialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/progressdialog/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/progressdialog/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/examples/qtconcurrent/progressdialog/CMakeLists.txt b/examples/qtconcurrent/progressdialog/CMakeLists.txt
deleted file mode 100644
index f1c07b7824..0000000000
--- a/examples/qtconcurrent/progressdialog/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-# Generated from progressdialog.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(progressdialog LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qtconcurrent/progressdialog")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Concurrent)
-find_package(Qt6 COMPONENTS Widgets)
-
-add_executable(progressdialog
- main.cpp
-)
-target_link_libraries(progressdialog PUBLIC
- Qt::Concurrent
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-install(TARGETS progressdialog
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)