summaryrefslogtreecommitdiffstats
path: root/examples/qtestlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtestlib/CMakeLists.txt')
-rw-r--r--examples/qtestlib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/qtestlib/CMakeLists.txt b/examples/qtestlib/CMakeLists.txt
index 83e7df5768..a98c499c00 100644
--- a/examples/qtestlib/CMakeLists.txt
+++ b/examples/qtestlib/CMakeLists.txt
@@ -1,5 +1,8 @@
# Generated from qtestlib.pro.
+if(NOT QT_BUILD_PARTS___contains___tools OR NOT TARGET Qt::Widgets)
+ return()
+endif()
add_subdirectory(tutorial1)
add_subdirectory(tutorial2)
add_subdirectory(tutorial3)