summaryrefslogtreecommitdiffstats
path: root/examples/sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/CMakeLists.txt')
-rw-r--r--examples/sql/CMakeLists.txt27
1 files changed, 14 insertions, 13 deletions
diff --git a/examples/sql/CMakeLists.txt b/examples/sql/CMakeLists.txt
index e54fc0860f..06d7d532d7 100644
--- a/examples/sql/CMakeLists.txt
+++ b/examples/sql/CMakeLists.txt
@@ -1,19 +1,20 @@
-# Generated from sql.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-if(NOT TARGET Qt::Widgets)
+if(NOT TARGET Qt6::Widgets)
return()
endif()
-add_subdirectory(books)
-add_subdirectory(drilldown)
-add_subdirectory(cachedtable)
-add_subdirectory(querymodel)
-add_subdirectory(relationaltablemodel)
-add_subdirectory(sqlwidgetmapper)
-add_subdirectory(tablemodel)
-if(TARGET Qt::Xml)
- add_subdirectory(masterdetail)
+qt_internal_add_example(books)
+qt_internal_add_example(drilldown)
+qt_internal_add_example(cachedtable)
+qt_internal_add_example(querymodel)
+qt_internal_add_example(relationaltablemodel)
+qt_internal_add_example(sqlwidgetmapper)
+qt_internal_add_example(tablemodel)
+if(TARGET Qt6::Xml)
+ qt_internal_add_example(masterdetail)
endif()
-if(NOT CMAKE_CROSSCOMPILING) # special case
- add_subdirectory(sqlbrowser)
+if(NOT CMAKE_CROSSCOMPILING)
+ qt_internal_add_example(sqlbrowser)
endif()