summaryrefslogtreecommitdiffstats
path: root/examples/sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/CMakeLists.txt')
-rw-r--r--examples/sql/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/examples/sql/CMakeLists.txt b/examples/sql/CMakeLists.txt
index b45fd6f7cc..06d7d532d7 100644
--- a/examples/sql/CMakeLists.txt
+++ b/examples/sql/CMakeLists.txt
@@ -1,6 +1,7 @@
-# Generated from sql.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-if(NOT TARGET Qt::Widgets)
+if(NOT TARGET Qt6::Widgets)
return()
endif()
qt_internal_add_example(books)
@@ -10,10 +11,10 @@ qt_internal_add_example(querymodel)
qt_internal_add_example(relationaltablemodel)
qt_internal_add_example(sqlwidgetmapper)
qt_internal_add_example(tablemodel)
-if(TARGET Qt::Xml)
+if(TARGET Qt6::Xml)
qt_internal_add_example(masterdetail)
endif()
-if(NOT CMAKE_CROSSCOMPILING) # special case
+if(NOT CMAKE_CROSSCOMPILING)
qt_internal_add_example(sqlbrowser)
endif()