summaryrefslogtreecommitdiffstats
path: root/examples/sql/books/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/books/CMakeLists.txt')
-rw-r--r--examples/sql/books/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/sql/books/CMakeLists.txt b/examples/sql/books/CMakeLists.txt
new file mode 100644
index 0000000000..e01adc1402
--- /dev/null
+++ b/examples/sql/books/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from books.pro.
+
+#####################################################################
+## books Binary:
+#####################################################################
+
+add_qt_executable(books
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/books"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/books"
+ SOURCES
+ bookdelegate.cpp bookdelegate.h
+ bookwindow.cpp bookwindow.h bookwindow.ui
+ initdb.h
+ main.cpp
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ LIBRARIES
+ Qt::Sql
+ Qt::Widgets
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(books "books" PREFIX "/" FILES
+ images/star.png)
+
+
+#### Keys ignored in scope 1:.:books.pro:<NONE>:
+# TEMPLATE = "app"