summaryrefslogtreecommitdiffstats
path: root/examples/sql/books/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/books/CMakeLists.txt')
-rw-r--r--examples/sql/books/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/examples/sql/books/CMakeLists.txt b/examples/sql/books/CMakeLists.txt
index 5890c6c85f..870d90bf14 100644
--- a/examples/sql/books/CMakeLists.txt
+++ b/examples/sql/books/CMakeLists.txt
@@ -9,14 +9,15 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/sql/books")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Sql)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(books
bookdelegate.cpp bookdelegate.h
- books.qrc
bookwindow.cpp bookwindow.h bookwindow.ui
initdb.h
main.cpp
@@ -24,11 +25,27 @@ add_qt_gui_executable(books
target_include_directories(books PUBLIC
.
)
+
target_link_libraries(books PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Sql
Qt::Widgets
)
+
+# Resources:
+set(books_resource_files
+ "images/star.png"
+)
+
+qt6_add_resources(books "books"
+ PREFIX
+ "/"
+ FILES
+ ${books_resource_files}
+)
+
install(TARGETS books
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"