summaryrefslogtreecommitdiffstats
path: root/examples/sql/drilldown/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/drilldown/CMakeLists.txt')
-rw-r--r--examples/sql/drilldown/CMakeLists.txt23
1 files changed, 21 insertions, 2 deletions
diff --git a/examples/sql/drilldown/CMakeLists.txt b/examples/sql/drilldown/CMakeLists.txt
index 128ebc107f..5b6bea0423 100644
--- a/examples/sql/drilldown/CMakeLists.txt
+++ b/examples/sql/drilldown/CMakeLists.txt
@@ -9,24 +9,43 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/sql/drilldown")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Sql)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(drilldown
../connection.h
- drilldown.qrc
imageitem.cpp imageitem.h
informationwindow.cpp informationwindow.h
main.cpp
view.cpp view.h
)
target_link_libraries(drilldown PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Sql
Qt::Widgets
)
+
+# Resources:
+set(drilldown_resource_files
+ "images/qt-creator.png"
+ "images/qt-logo.png"
+ "images/qt-project.png"
+ "images/qt-quick.png"
+)
+
+qt6_add_resources(drilldown "drilldown"
+ PREFIX
+ "/"
+ FILES
+ ${drilldown_resource_files}
+)
+
install(TARGETS drilldown
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"