summaryrefslogtreecommitdiffstats
path: root/examples/sql/masterdetail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/masterdetail/CMakeLists.txt')
-rw-r--r--examples/sql/masterdetail/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/sql/masterdetail/CMakeLists.txt b/examples/sql/masterdetail/CMakeLists.txt
new file mode 100644
index 0000000000..8c73675e55
--- /dev/null
+++ b/examples/sql/masterdetail/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from masterdetail.pro.
+
+#####################################################################
+## masterdetail Binary:
+#####################################################################
+
+add_qt_executable(masterdetail
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/masterdetail"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/masterdetail"
+ SOURCES
+ database.h
+ dialog.cpp dialog.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ LIBRARIES
+ Qt::Sql
+ Qt::Widgets
+ Qt::Xml
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(masterdetail "masterdetail" FILES
+ images/icon.png
+ images/image.png)
+
+
+#### Keys ignored in scope 1:.:masterdetail.pro:<NONE>:
+# EXAMPLE_FILES = "albumdetails.xml"