summaryrefslogtreecommitdiffstats
path: root/examples/sql/masterdetail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/masterdetail/CMakeLists.txt')
-rw-r--r--examples/sql/masterdetail/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/examples/sql/masterdetail/CMakeLists.txt b/examples/sql/masterdetail/CMakeLists.txt
new file mode 100644
index 0000000000..7052461601
--- /dev/null
+++ b/examples/sql/masterdetail/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Generated from masterdetail.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(masterdetail LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/sql/masterdetail")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Sql)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS Xml)
+
+add_qt_gui_executable(masterdetail
+ database.h
+ dialog.cpp dialog.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+target_link_libraries(masterdetail PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Sql
+ Qt::Widgets
+ Qt::Xml
+)
+
+
+# Resources:
+set(masterdetail_resource_files
+ "images/icon.png"
+ "images/image.png"
+)
+
+qt6_add_resources(masterdetail "masterdetail"
+ PREFIX
+ "/"
+ FILES
+ ${masterdetail_resource_files}
+)
+
+install(TARGETS masterdetail
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)