summaryrefslogtreecommitdiffstats
path: root/examples/sql/relationaltablemodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/relationaltablemodel/CMakeLists.txt')
-rw-r--r--examples/sql/relationaltablemodel/CMakeLists.txt38
1 files changed, 25 insertions, 13 deletions
diff --git a/examples/sql/relationaltablemodel/CMakeLists.txt b/examples/sql/relationaltablemodel/CMakeLists.txt
index d31042cc73..de4dba49cc 100644
--- a/examples/sql/relationaltablemodel/CMakeLists.txt
+++ b/examples/sql/relationaltablemodel/CMakeLists.txt
@@ -1,17 +1,29 @@
# Generated from relationaltablemodel.pro.
-#####################################################################
-## relationaltablemodel Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(relationaltablemodel LANGUAGES CXX)
-add_qt_executable(relationaltablemodel
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/relationaltablemodel"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/sql/relationaltablemodel"
- SOURCES
- ../connection.h
- relationaltablemodel.cpp
- LIBRARIES
- Qt::Sql
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Sql)
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(relationaltablemodel WIN32 MACOSX_BUNDLE
+ ../connection.h
+ relationaltablemodel.cpp
+)
+target_link_libraries(relationaltablemodel PUBLIC
+ Qt::Sql
+ Qt::Widgets
+)
+
+install(TARGETS relationaltablemodel
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)