summaryrefslogtreecommitdiffstats
path: root/examples/sql/tablemodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/tablemodel/CMakeLists.txt')
-rw-r--r--examples/sql/tablemodel/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/sql/tablemodel/CMakeLists.txt b/examples/sql/tablemodel/CMakeLists.txt
index 9e90e56b7f..85e1bd9167 100644
--- a/examples/sql/tablemodel/CMakeLists.txt
+++ b/examples/sql/tablemodel/CMakeLists.txt
@@ -9,8 +9,10 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/sql/tablemodel")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Sql)
find_package(Qt6 COMPONENTS Widgets)
@@ -19,6 +21,8 @@ add_qt_gui_executable(tablemodel
tablemodel.cpp
)
target_link_libraries(tablemodel PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Sql
Qt::Widgets
)