summaryrefslogtreecommitdiffstats
path: root/examples/sql/tablemodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sql/tablemodel/CMakeLists.txt')
-rw-r--r--examples/sql/tablemodel/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/sql/tablemodel/CMakeLists.txt b/examples/sql/tablemodel/CMakeLists.txt
new file mode 100644
index 0000000000..9e90e56b7f
--- /dev/null
+++ b/examples/sql/tablemodel/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from tablemodel.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(tablemodel LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Sql)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(tablemodel
+ ../connection.h
+ tablemodel.cpp
+)
+target_link_libraries(tablemodel PUBLIC
+ Qt::Sql
+ Qt::Widgets
+)
+
+install(TARGETS tablemodel
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)