summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/hellovulkantriangle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vulkan/hellovulkantriangle/CMakeLists.txt')
-rw-r--r--examples/vulkan/hellovulkantriangle/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/examples/vulkan/hellovulkantriangle/CMakeLists.txt b/examples/vulkan/hellovulkantriangle/CMakeLists.txt
new file mode 100644
index 0000000000..dae891ea07
--- /dev/null
+++ b/examples/vulkan/hellovulkantriangle/CMakeLists.txt
@@ -0,0 +1,50 @@
+# Generated from hellovulkantriangle.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(hellovulkantriangle LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/vulkan/hellovulkantriangle")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+
+add_qt_gui_executable(hellovulkantriangle
+ ../shared/trianglerenderer.cpp ../shared/trianglerenderer.h
+ main.cpp
+)
+target_link_libraries(hellovulkantriangle PUBLIC
+ Qt::Core
+ Qt::Gui
+)
+
+
+# Resources:
+set_source_files_properties("../shared/color_frag.spv"
+ PROPERTIES QT_RESOURCE_ALIAS "color_frag.spv"
+)
+set_source_files_properties("../shared/color_vert.spv"
+ PROPERTIES QT_RESOURCE_ALIAS "color_vert.spv"
+)
+set(hellovulkantriangle_resource_files
+ "../shared/color_frag.spv"
+ "../shared/color_vert.spv"
+)
+
+qt6_add_resources(hellovulkantriangle "hellovulkantriangle"
+ PREFIX
+ "/"
+ FILES
+ ${hellovulkantriangle_resource_files}
+)
+
+install(TARGETS hellovulkantriangle
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)