summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/hellovulkanwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vulkan/hellovulkanwidget/CMakeLists.txt')
-rw-r--r--examples/vulkan/hellovulkanwidget/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/examples/vulkan/hellovulkanwidget/CMakeLists.txt b/examples/vulkan/hellovulkanwidget/CMakeLists.txt
new file mode 100644
index 0000000000..281c49e77d
--- /dev/null
+++ b/examples/vulkan/hellovulkanwidget/CMakeLists.txt
@@ -0,0 +1,53 @@
+# Generated from hellovulkanwidget.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(hellovulkanwidget LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(hellovulkanwidget
+ ../shared/trianglerenderer.cpp ../shared/trianglerenderer.h
+ hellovulkanwidget.cpp hellovulkanwidget.h
+ main.cpp
+)
+target_link_libraries(hellovulkanwidget PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+# Resources:
+set_source_files_properties("../shared/color_frag.spv"
+ PROPERTIES QT_RESOURCE_ALIAS "color_frag.spv"
+)
+set_source_files_properties("../shared/color_vert.spv"
+ PROPERTIES QT_RESOURCE_ALIAS "color_vert.spv"
+)
+set(hellovulkanwidget_resource_files
+ "../shared/color_frag.spv"
+ "../shared/color_vert.spv"
+)
+
+qt6_add_resources(hellovulkanwidget "hellovulkanwidget"
+ PREFIX
+ "/"
+ FILES
+ ${hellovulkanwidget_resource_files}
+)
+
+
+install(TARGETS hellovulkanwidget
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)