summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/hellovulkanwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vulkan/hellovulkanwindow/CMakeLists.txt')
-rw-r--r--examples/vulkan/hellovulkanwindow/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/examples/vulkan/hellovulkanwindow/CMakeLists.txt b/examples/vulkan/hellovulkanwindow/CMakeLists.txt
deleted file mode 100644
index 7323bab06c..0000000000
--- a/examples/vulkan/hellovulkanwindow/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-cmake_minimum_required(VERSION 3.16)
-project(hellovulkanwindow LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/vulkan/hellovulkanwindow")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui)
-
-qt_add_executable(hellovulkanwindow
- hellovulkanwindow.cpp hellovulkanwindow.h
- main.cpp
-)
-
-set_target_properties(hellovulkanwindow PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(hellovulkanwindow PUBLIC
- Qt::Core
- Qt::Gui
-)
-
-install(TARGETS hellovulkanwindow
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)