summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/animatedtiles/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/animation/animatedtiles/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/animatedtiles/CMakeLists.txt43
1 files changed, 22 insertions, 21 deletions
diff --git a/examples/widgets/animation/animatedtiles/CMakeLists.txt b/examples/widgets/animation/animatedtiles/CMakeLists.txt
index 0af95adcf8..dacde5535c 100644
--- a/examples/widgets/animation/animatedtiles/CMakeLists.txt
+++ b/examples/widgets/animation/animatedtiles/CMakeLists.txt
@@ -1,26 +1,27 @@
# Generated from animatedtiles.pro.
-#####################################################################
-## animatedtiles Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(animatedtiles LANGUAGES CXX)
-add_qt_executable(animatedtiles
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/animatedtiles"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/animatedtiles"
- SOURCES
- main.cpp
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-# Resources:
-add_qt_resource(animatedtiles "animatedtiles" FILES
- images/Time-For-Lunch-2.jpg
- images/centered.png
- images/ellipse.png
- images/figure8.png
- images/kinetic.png
- images/random.png
- images/tile.png)
+set(INSTALL_EXAMPLEDIR "examples")
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(animatedtiles WIN32 MACOSX_BUNDLE
+ animatedtiles.qrc
+ main.cpp
+)
+target_link_libraries(animatedtiles PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS animatedtiles
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)