summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/easing/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/animation/easing/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/easing/CMakeLists.txt45
1 files changed, 25 insertions, 20 deletions
diff --git a/examples/widgets/animation/easing/CMakeLists.txt b/examples/widgets/animation/easing/CMakeLists.txt
index b7444412a6..1500b11f3b 100644
--- a/examples/widgets/animation/easing/CMakeLists.txt
+++ b/examples/widgets/animation/easing/CMakeLists.txt
@@ -1,25 +1,30 @@
# Generated from easing.pro.
-#####################################################################
-## easing Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(easing LANGUAGES CXX)
-add_qt_executable(easing
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/easing"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/easing"
- SOURCES
- animation.h
- form.ui
- main.cpp
- window.cpp window.h
- PUBLIC_LIBRARIES
- Qt::Widgets
- ENABLE_AUTOGEN_TOOLS
- uic
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-# Resources:
-add_qt_resource(easing "easing" FILES
- images/qt-logo.png)
+set(INSTALL_EXAMPLEDIR "examples")
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(easing WIN32 MACOSX_BUNDLE
+ animation.h
+ easing.qrc
+ form.ui
+ main.cpp
+ window.cpp window.h
+)
+target_link_libraries(easing PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS easing
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)