summaryrefslogtreecommitdiffstats
path: root/examples/widgets/draganddrop/puzzle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/draganddrop/puzzle/CMakeLists.txt')
-rw-r--r--examples/widgets/draganddrop/puzzle/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/examples/widgets/draganddrop/puzzle/CMakeLists.txt b/examples/widgets/draganddrop/puzzle/CMakeLists.txt
index 9cb2a85437..cf6350f16d 100644
--- a/examples/widgets/draganddrop/puzzle/CMakeLists.txt
+++ b/examples/widgets/draganddrop/puzzle/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from puzzle.pro.
-
cmake_minimum_required(VERSION 3.16)
project(puzzle LANGUAGES CXX)
@@ -13,21 +11,21 @@ if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/draganddrop_puzzle") # special case
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/draganddrop_puzzle")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-qt_add_executable(draganddrop_puzzle # special case: renamed puzzle
+qt_add_executable(draganddrop_puzzle
main.cpp
mainwindow.cpp mainwindow.h
pieceslist.cpp pieceslist.h
puzzlewidget.cpp puzzlewidget.h
)
-set_target_properties(draganddrop_puzzle PROPERTIES # special case
+set_target_properties(draganddrop_puzzle PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_link_libraries(draganddrop_puzzle PUBLIC # special case
+target_link_libraries(draganddrop_puzzle PUBLIC
Qt::Core
Qt::Gui
Qt::Widgets
@@ -39,14 +37,14 @@ set(puzzle_resource_files
"example.jpg"
)
-qt_add_resources(draganddrop_puzzle "puzzle" # special case
+qt_add_resources(draganddrop_puzzle "puzzle"
PREFIX
"/images"
FILES
${puzzle_resource_files}
)
-install(TARGETS draganddrop_puzzle # special case: renamed puzzle
+install(TARGETS draganddrop_puzzle
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"