summaryrefslogtreecommitdiffstats
path: root/examples/widgets/effects/blurpicker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/effects/blurpicker/CMakeLists.txt')
-rw-r--r--examples/widgets/effects/blurpicker/CMakeLists.txt29
1 files changed, 27 insertions, 2 deletions
diff --git a/examples/widgets/effects/blurpicker/CMakeLists.txt b/examples/widgets/effects/blurpicker/CMakeLists.txt
index 030de7fe93..3f9fa69797 100644
--- a/examples/widgets/effects/blurpicker/CMakeLists.txt
+++ b/examples/widgets/effects/blurpicker/CMakeLists.txt
@@ -9,19 +9,44 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/widgets/effects/blurpicker")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(blurpicker
blureffect.cpp blureffect.h
- blurpicker.cpp blurpicker.h blurpicker.qrc
+ blurpicker.cpp blurpicker.h
main.cpp
)
target_link_libraries(blurpicker PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
+
+# Resources:
+set(blurpicker_resource_files
+ "images/accessories-calculator.png"
+ "images/accessories-text-editor.png"
+ "images/background.jpg"
+ "images/help-browser.png"
+ "images/internet-group-chat.png"
+ "images/internet-mail.png"
+ "images/internet-web-browser.png"
+ "images/office-calendar.png"
+ "images/system-users.png"
+)
+
+qt6_add_resources(blurpicker "blurpicker"
+ PREFIX
+ "/"
+ FILES
+ ${blurpicker_resource_files}
+)
+
install(TARGETS blurpicker
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"