summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/boxes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/graphicsview/boxes/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/boxes/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/examples/widgets/graphicsview/boxes/CMakeLists.txt b/examples/widgets/graphicsview/boxes/CMakeLists.txt
new file mode 100644
index 0000000000..af2891ffb1
--- /dev/null
+++ b/examples/widgets/graphicsview/boxes/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Generated from boxes.pro.
+
+qt_find_package(WrapOpenGL PROVIDED_TARGETS WrapOpenGL) # special case
+#####################################################################
+## boxes Binary:
+#####################################################################
+
+add_qt_executable(boxes
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/boxes"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/boxes"
+ SOURCES
+ 3rdparty/fbm.c 3rdparty/fbm.h
+ glbuffers.cpp glbuffers.h
+ glextensions.cpp glextensions.h
+ gltrianglemesh.h
+ main.cpp
+ qtbox.cpp qtbox.h
+ roundedbox.cpp roundedbox.h
+ scene.cpp scene.h
+ trackball.cpp trackball.h
+ LIBRARIES
+ Qt::OpenGL
+ Qt::Widgets
+ WrapOpenGL
+)
+
+# Resources:
+add_qt_resource(boxes "boxes" PREFIX "/res/boxes" FILES
+ basic.fsh
+ basic.vsh
+ cubemap_negx.jpg
+ cubemap_negy.jpg
+ cubemap_negz.jpg
+ cubemap_posx.jpg
+ cubemap_posy.jpg
+ cubemap_posz.jpg
+ dotted.fsh
+ fresnel.fsh
+ glass.fsh
+ granite.fsh
+ marble.fsh
+ parameters.par
+ qt-logo.jpg
+ qt-logo.png
+ reflection.fsh
+ refraction.fsh
+ smiley.png
+ square.jpg
+ wood.fsh)
+
+
+## Scopes:
+#####################################################################