summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/chip/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/graphicsview/chip/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/chip/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/examples/widgets/graphicsview/chip/CMakeLists.txt b/examples/widgets/graphicsview/chip/CMakeLists.txt
new file mode 100644
index 0000000000..566a8aae02
--- /dev/null
+++ b/examples/widgets/graphicsview/chip/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from chip.pro.
+
+#####################################################################
+## chip Binary:
+#####################################################################
+
+add_qt_executable(chip
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/chip"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/chip"
+ SOURCES
+ chip.cpp chip.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ view.cpp view.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(chip "images" FILES
+ fileprint.png
+ qt4logo.png
+ rotateleft.png
+ rotateright.png
+ zoomin.png
+ zoomout.png)
+
+
+## Scopes:
+#####################################################################
+
+extend_target(chip CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)
+
+extend_target(chip CONDITION TARGET Qt::OpenGL
+ LIBRARIES
+ Qt::OpenGL
+)
+
+#### Keys ignored in scope 4:.:chip.pro:build_all AND NOT build_pass:
+# CONFIG = "-build_all" "release"