summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt57
1 files changed, 0 insertions, 57 deletions
diff --git a/examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt b/examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt
deleted file mode 100644
index 2aa69e59a0..0000000000
--- a/examples/widgets/graphicsview/weatheranchorlayout/CMakeLists.txt
+++ /dev/null
@@ -1,57 +0,0 @@
-# Generated from weatheranchorlayout.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(weatheranchorlayout LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/weatheranchorlayout")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-
-qt_add_executable(weatheranchorlayout
- main.cpp
-)
-set_target_properties(weatheranchorlayout PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(weatheranchorlayout PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-
-# Resources:
-set(weatheranchorlayout_resource_files
- "images/5days.jpg"
- "images/details.jpg"
- "images/place.jpg"
- "images/tabbar.jpg"
- "images/title.jpg"
- "images/weather-few-clouds.png"
-)
-
-qt6_add_resources(weatheranchorlayout "weatheranchorlayout"
- PREFIX
- "/"
- FILES
- ${weatheranchorlayout_resource_files}
-)
-
-install(TARGETS weatheranchorlayout
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)