summaryrefslogtreecommitdiffstats
path: root/examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt')
-rw-r--r--examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt b/examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt
new file mode 100644
index 0000000000..6cbfa84ae1
--- /dev/null
+++ b/examples/widgets/itemviews/customsortfiltermodel/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from customsortfiltermodel.pro.
+
+#####################################################################
+## customsortfiltermodel Binary:
+#####################################################################
+
+add_qt_executable(customsortfiltermodel
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/customsortfiltermodel"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/customsortfiltermodel"
+ SOURCES
+ filterwidget.cpp filterwidget.h
+ main.cpp
+ mysortfilterproxymodel.cpp mysortfilterproxymodel.h
+ window.cpp window.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(customsortfiltermodel "customsortfiltermodel" PREFIX "/" FILES
+ images/find.png)
+