summaryrefslogtreecommitdiffstats
path: root/examples/widgets/itemviews/pixelator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/itemviews/pixelator/CMakeLists.txt')
-rw-r--r--examples/widgets/itemviews/pixelator/CMakeLists.txt49
1 files changed, 27 insertions, 22 deletions
diff --git a/examples/widgets/itemviews/pixelator/CMakeLists.txt b/examples/widgets/itemviews/pixelator/CMakeLists.txt
index fc29cde3b1..e9a04a0807 100644
--- a/examples/widgets/itemviews/pixelator/CMakeLists.txt
+++ b/examples/widgets/itemviews/pixelator/CMakeLists.txt
@@ -1,31 +1,36 @@
# Generated from pixelator.pro.
-#####################################################################
-## pixelator Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(pixelator LANGUAGES CXX)
-add_qt_executable(pixelator
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/pixelator"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/pixelator"
- SOURCES
- imagemodel.cpp imagemodel.h
- main.cpp
- mainwindow.cpp mainwindow.h
- pixeldelegate.cpp pixeldelegate.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-# Resources:
-add_qt_resource(pixelator "images" FILES
- images/qt.png)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+set(INSTALL_EXAMPLEDIR "examples")
-## Scopes:
-#####################################################################
+find_package(Qt5 COMPONENTS Widgets)
+find_package(Qt5 COMPONENTS PrintSupport) # special case
-extend_target(pixelator CONDITION TARGET Qt::PrintSupport
- LIBRARIES
+add_executable(pixelator WIN32 MACOSX_BUNDLE
+ imagemodel.cpp imagemodel.h
+ images.qrc
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ pixeldelegate.cpp pixeldelegate.h
+)
+target_link_libraries(pixelator PUBLIC
+ Qt::Widgets
+)
+if (TARGET Qt::PrintSupport)
+ target_link_libraries(pixelator PUBLIC
Qt::PrintSupport
+ )
+endif()
+
+install(TARGETS pixelator
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)