summaryrefslogtreecommitdiffstats
path: root/examples/widgets/itemviews/pixelator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/itemviews/pixelator/CMakeLists.txt')
-rw-r--r--examples/widgets/itemviews/pixelator/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/examples/widgets/itemviews/pixelator/CMakeLists.txt b/examples/widgets/itemviews/pixelator/CMakeLists.txt
new file mode 100644
index 0000000000..fc29cde3b1
--- /dev/null
+++ b/examples/widgets/itemviews/pixelator/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from pixelator.pro.
+
+#####################################################################
+## pixelator Binary:
+#####################################################################
+
+add_qt_executable(pixelator
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/pixelator"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/itemviews/pixelator"
+ SOURCES
+ imagemodel.cpp imagemodel.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ pixeldelegate.cpp pixeldelegate.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(pixelator "images" FILES
+ images/qt.png)
+
+
+## Scopes:
+#####################################################################
+
+extend_target(pixelator CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)